如何在Linux下调试iOS Safari/Safari Webview

移动端的开发越来越多,在移动端上真机调试Web应用也是一个对于开发者而言比较强烈的刚需。google就做了一个叫ios_webkit_debug_proxy的东西,大部分博客或者文章对它的介绍基本上偏向于这个工具是让喜爱Chrome的开发者在不采用safari的调试工具下调试IOS Web应用,但我觉得这个工具更适合的定位是,非Mac调试IOS Web应用的开发者。
废话不多说,以Ubuntu为例,大致讲解如何在Linux系统上安装该程序。
git地址是:https://github.com/google/ios-webkit-debug-proxy
这个程序是多平台的,所以无论在Linux上还是Mac OS上甚至Windows上都可以使用,大部分安装方法都大同小异。好多前端开发者还是喜欢Windows下开发,不过我就不讲述Windows下的安装方法,请自行研究。
Github的Readme中讲述的非常简单,

On Linux or Mac:

sudo apt-get install autoconf automake libusb-dev libusb-1.0-0-dev libplist-dev libplist++-dev usbmuxd libtool libimobiledevice-dev

git clone https://github.com/google/ios-webkit-debug-proxy.git
cd ios-webkit-debug-proxy

./autogen.sh
make
sudo make install

但如果觉得安装确实是这么简单的,那实在是太天真了(我也天真过。。。),如果你按照这个方法安装,则会提示依赖版本过低,无法安装。所以如果想使用这个软件,先要安装好相关依赖。

ios-webkit-debug-proxy 主要依赖libimobiledevice,libusbmuxd,libplist这三个库,但libimobiledevice安装会异常的辛苦,因为这个东西的依赖稍微有些多

Sources and Dependencies:

libimobiledevice-1.2.0.tar.bz2
ifuse-1.1.3.tar.bz2
libplist-1.12.tar.bz2
libusbmuxd-1.0.10.tar.bz2
usbmuxd-1.1.0.tar.bz2 (needs libusb >= 1.0.3)
ideviceinstaller-1.1.0.tar.bz2
libideviceactivation-1.0.0.tar.bz2

这些都需要下载下来,地址在http://www.libimobiledevice.org/
make && sudo make install

git clone https://github.com/google/ios-webkit-debug-proxy.git

make && sudo make install

注意的是不要认为机器上已经有一些lib就不下载,根据我踩到的坑,基本上都要手动编译安装,要不然各种问题。

特别是libusbmuxd 这个在ubuntu操作系统中的默认版本相当低,容易出错又没有办法连接,务必注意。

./ios-webkit-debug-proxy 执行一下
连接机器
http://localhost:9222
点击所要调试的页面 enjoy.

发表评论

电子邮件地址不会被公开。 必填项已用*标注